Задать вопрос
11 февраля, 13:26

Дан список чисел. Выведите все элементы списка, которые больше предыдущего элемента. Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные данные Выведите ответ на задачу. Примеры входные данные 1 5 2 4 3 выходные данные 5 4

+4
Ответы (1)
  1. 11 февраля, 17:25
    0
    Const n=10;

    var a: array[1 ... n] of integer;

    i: integer;

    begin

    randomize;

    writeln ('список:') ;

    for i:=1 to n do

    begin

    a[i]:=random (-20,20) ;

    write (a[i],' ') ;

    end;

    writeln;

    for i:=2 to n do

    if a[i]>a[i-1] then write (a[i]:4) ;

    end.

    список:

    -20 - 20 - 14 - 18 20 12 - 2 - 6 - 13 15

    -14 20 15

    Если ввод с клавиатуры:

    var a: array of integer;

    i, n: integer;

    begin

    write ('n = ') ; readln (n) ;

    setlength (a, n+1) ;

    for i:=1 to n do read (a[i]) ;

    for i:=2 to n do

    if a[i]>a[i-1] then write (a[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан список чисел. Выведите все элементы списка, которые больше предыдущего элемента. Входные данные Вводится список чисел. Все числа списка ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы