Задать вопрос
11 февраля, 09:08

Составьте программу, определяющую, лежит ли точка с

указанными координатами X, Y на окружности радиуса R с центром в

начале координат.

Program Frankenstein;

var

x, y, r:integer;

Begin

Write ('Введите координату X: ') ;

Readln (x) ;

Write ('Введите координату Y: ') ;

Readln (y) ;

Write ('Введите длину радиуса R: ') ;

Readln (r) ;

If (sqr (x) + sqr (y)) = r

then writeln ('Точка лежит на

окружности!')

Else writeln ('Точка не лежит на

окружности!') ;

End.

Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?

+2
Ответы (1)
  1. 11 февраля, 11:20
    0
    R^2

    Var

    x, y, r:integer;

    Begin

    Write ('Введите координату X: ') ;

    Readln (x) ;

    Write ('Введите координату Y: ') ;

    Readln (y) ;

    Write ('Введите длину радиуса R: ') ;

    Readln (r) ;

    If (sqr (x) + sqr (y)) = sqr (r) then

    writeln ('Точка лежит на окружности!')

    Else writeln ('Точка не лежит на окружности!') ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы