Задать вопрос
21 октября, 11:26

Pascal ABC

Напишите программу, которая определяет количество элементов, сумма цифр которых четна.

Формат ввода

Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода).

Формат вывода

Выведите одно число - количество чисел, сумма цифр которых четна

Пример

Ввод Вывод

2 4

3

4

1444

4

5

136

0

+3
Ответы (1)
  1. 21 октября, 13:15
    0
    Program n1;

    var a, k: integer;

    function summa (n: integer) : integer;

    var s: integer;

    begin

    s:=0;

    while n>0 do

    begin

    s:=s+n mod 10;

    n:=n div 10;

    end;

    summa:=s;

    end;

    begin

    k:=0;

    write ('введите 1 число: ') ;

    readln (a) ;

    if (summa (a) mod 2=0) and (a0) then k:=k+1;

    while a0 do

    begin

    write ('введите следущее число: ') ;

    readln (a) ;

    if (summa (a) mod 2=0) and (a0) then k:=k+1;

    end;

    writeln ('количество: ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3. Программа получает на вход целые числа.
Ответы (1)