Задать вопрос
14 ноября, 16:39

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6. Программа получает на вод натуральные числа, кол-во введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Программа должна вывести одно число: сумма четырехзначных чисел, кратных 6.

2) Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратно 3 и оканчивающиеся на 3. программа получает на вход кол-во чисел в последовательности, а заем сами числа. В последовательности всегда имеется число, кратное 3 и оканчивающиеся на 3. Кол-во чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число - максимальное число, кратное 3 и оканчивающиеся на 3.

+5
Ответы (1)
  1. 14 ноября, 17:47
    0
    1)

    Program n1;

    var a: integer;

    sum: real;

    begin

    readln (a) ;

    sum:=0;

    while a0 do

    begin

    if (a>999) and (a<10000) and (a mod 6=0) then sum:=sum+a;

    readln (a) ;

    end;

    writeln (sum) ;

    end.

    2)

    Program n2;

    var a, max, i, n: integer;

    begin

    readln (n) ;

    max:=-30000;

    for i:=1 to n do

    begin

    readln (a) ;

    if (a>max) and (a mod 3=0) and (a mod 10=3) then max:=a;

    end;

    writeln (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6. Программа получает ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы