Задать вопрос
9 мая, 06:54

В Паскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с нулем)

+3
Ответы (1)
  1. 9 мая, 08:04
    0
    Var a, b, c, x1, x2, D:real;

    begin

    writeln ('Введите значение a, b и c') ;

    readln (a, b, c) ;

    D:=sqr (b) - 4*a*c;

    if D>0 then

    begin

    x1: = (-b+sqrt (D)) / 2*a;

    x2: = (-b-sqrt (D)) / 2*a;

    writeln ('x1 = ', x1, ' x2 = ', x2) end

    else

    writeln ('Корней нет') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В Паскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы