Задать вопрос
6 июля, 00:48

Напишите рекурсивную функцию вычисления суммы цифр натурального числа.

Формат входных данных

На вход ваша программа получает одно натуральное число n (n<216) (n<216).

Формат выходных данных

Выведите одно число - сумму цифр числа n.

+3
Ответы (1)
  1. 6 июля, 04:03
    0
    Var n: int64;

    function f (n: int64) : int64;

    begin

    if (n > 0) then f : = f (n div 10) + (n mod 10) ;

    end;

    begin

    readln (n) ;

    write (f (n)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы