Задать вопрос
19 июля, 18:42

2) Заполнить массив А случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных максимальному.

+2
Ответы (1)
  1. 19 июля, 21:40
    0
    Var mas: array[-1000 ... 1000] of integer;

    i, max, n: integer;

    begin

    {ввод количества элементов массива}

    readln (n) ;

    {ввод массива и его вывод на экран}

    randomize;

    for i : = 1 to n do

    begin

    mas[i] : = 50 - random (100) - 1;

    write (mas[i]:5) ;

    if (i mod 10 = 0) then writeln;

    end;

    {поиск максимума}

    max : = mas[1];

    for i : = 2 to n do

    if (mas[i] > max) then max : = mas[i];

    {нахождение номеров элементов массива}

    writeln;

    for i:=1 to n do if (mas[i] = max) then write (i,' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «2) Заполнить массив А случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы