Задать вопрос
2 октября, 19:40

Написать программу, сокращающую обыкновенные дроби. Числитель и знаменатель вводятся с клавиатуры. В программе использовать цикл с постусловием. Пример. вводятся числа: 10 15 результат: 2 / 3

+2
Ответы (1)
  1. 2 октября, 23:17
    0
    var i, x, y:integer;

    b:boolean;

    begin

    readln (x, y) ;

    for i:=2 to x do

    if (x div i=x/i) and (y div i=y/i) then begin

    x:=x div i;

    y:=y div i;

    end;

    writeln (x,' ', y) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, сокращающую обыкновенные дроби. Числитель и знаменатель вводятся с клавиатуры. В программе использовать цикл с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы