Задать вопрос
31 августа, 18:06

Помогите составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника.

+1
Ответы (1)
  1. 31 августа, 21:29
    0
    var

    a, b, c, g : integer;

    / / a, b, c - стороны

    begin

    readln (a, b, c) ;

    / / g - находим гипотенузу (наибольшее из чисел)

    if a > b then

    begin

    if a > c then

    g : = a

    else

    g : = c

    end

    else

    if b > c

    then

    g : = b

    else

    g : = c;

    / / Если треугольник прямоугольный, то

    / / сумма квадратов катетов равна квадрату гипотенузы

    if (sqr (a) + sqr (b) = sqr (g))

    or (sqr (a) + sqr (c) = sqr (g)) then

    writeln ('Yes')

    else writeln ('No') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы