Задать вопрос
8 июня, 14:00

Напишите программу. Определить номер подъезда и этаж квартиры по её номеру, если известна этажность дома и количество квартир на лестничной площадке

+1
Ответы (1)
  1. 8 июня, 17:49
    0
    Program P1;

    var z, x, y, p, e:integer;

    begin

    write ('Количество этажей = ') ; readln (x) ;

    write ('Количество квартир на лестничной площадке = ') ;

    readln (y) ;

    write ('Номер квартиры = ') ; readln (z) ;

    p: = (z-1) div (x*y) + 1;

    e: = ((z - (p-1) * x*y) - 1) div y + 1;

    writeln ('Квартира ', z,' находится в ', p,' подъезде на ', e,' этаже') ;

    end.

    Пример:

    Количество этажей = 9

    Количество квартир на лестничной площадке = 4

    Номер квартиры = 67

    Квартира 67 находится в 2 подъезде на 8 этаже
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу. Определить номер подъезда и этаж квартиры по её номеру, если известна этажность дома и количество квартир на лестничной ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы