Задать вопрос
22 августа, 20:40

Составить программу в pascal для нахождения корней квадратного уравнения ax^2+bx+c=0

+2
Ответы (1)
  1. 22 августа, 22:36
    0
    Uses crt;

    var

    d, a, b, c, x1, x2: real;

    begin

    writeln ('Введите a, b, c') ;

    readln (a, b, c) ;

    d : = b * b - 4 * a * c;

    if d > 0 then

    begin

    x1 : = (-b + sqrt (d)) / (2 * a) ;

    x2 : = (-b - sqrt (d)) / (2 * a) ;

    writeln ('x1 = ', x1:2:2) ;

    writeln ('x2 = ', x2:2:2) ;

    end

    else if d = 0 then

    begin

    x1 : = - b / (2 * a) ;

    writeln ('x = ', x1:2:2) ;

    end

    else

    writeln ('Нет действительных корней') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в pascal для нахождения корней квадратного уравнения ax^2+bx+c=0 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы