Задать вопрос
29 августа, 10:42

Помогите с Паскалем. Нужно написать программу, которая с помощью функции, выводит наибольшую цифру в введенном числе.

+5
Ответы (1)
  1. 29 августа, 14:20
    0
    Var a:integer;

    function max (n:integer) : integer;

    var m:integer;

    begin

    n:=abs (n) ;

    m:=0;

    while n0 do

    begin

    if n mod 10 > m then m:=n mod 10;

    n:=n div 10;

    end;

    max:=m;

    end;

    begin

    write ('a = ') ;

    readln (a) ;

    writeln ('Максимальная цифра = ', max (a)) ;

    end.

    Пример:

    a = - 185

    Максимальная цифра = 8
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите с Паскалем. Нужно написать программу, которая с помощью функции, выводит наибольшую цифру в введенном числе. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы