Задать вопрос
29 августа, 11:50

Найти все двузначные числа, которые делятся на n и содержат в себе цифру n

P. S. написать программу в Паскале через цикл while

+2
Ответы (1)
  1. 29 августа, 15:37
    0
    Var

    A, N, C:byte;

    B:boolean;

    Begin

    B:=false;

    Write ('N = ') ; ReadLn (N) ;

    A:=10;

    While A<100 do

    Begin

    if A mod N = 0 then

    Begin

    C:=A;

    While C0 do

    Begin

    if C mod 10 = N then B:=true;

    C:=C div 10

    End;

    if B then Write (A,' ') ;

    B:=false

    End;

    A:=A+1

    End

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти все двузначные числа, которые делятся на n и содержат в себе цифру n P. S. написать программу в Паскале через цикл while ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы