Задать вопрос
29 июля, 11:19

Помогите решить в паскале

1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6.

2) Введено 3-значное число. Вывести число в зеркальном отображении.

3) Введенное 4-значное число изменить так, чтобы 1-3 и 2-4 цифры поменялись местами.

+5
Ответы (1)
  1. 29 июля, 13:58
    0
    Program task1;

    var a : integer;

    begin

    randomize; a: = 0; while (a 5) and (a 6) do a: = random (7) ; writeln (a) ;

    end.

    program task2;

    var Digit, i : integer; DigitStr : string;

    begin

    readln (Digit) ; str (Digit, DigitStr) ; for i: = length (DigitStr) downto 1 do write (DigitStr[i]) ;

    end.

    program task3;

    var Digit : integer; NewDigit, DigitStr : string;

    begin

    readln (Digit) ; str (Digit, DigitStr) ; NewDigit: = DigitStr[3] + DigitStr[4] + DigitStr[1] + DigitStr[2]; writeln (NewDigit) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить в паскале 1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы