Задать вопрос
7 января, 17:10

Написать программу на Паскале, которая формирует случайным образом массив из n - целых чисел, лежащих в диапозоне от 1 до 5, вывести сма массив и номера элементов совпадающих с первым элементом.

+3
Ответы (1)
  1. 7 января, 19:44
    0
    program zadanie;

    var

    a: array[1 ... 99999] of real;

    i, n: integer;

    begin

    randomize;

    write ('Введите число чисел массива: ') ; readln (n) ;

    for i:=1 to n do

    begin

    a[i]:=1+random (5) ;

    writeln ('a[', i, ']=', a[i]) ;

    end;

    write ('Номера элементов, совпадающих с первым элементом: ') ;

    for i:=1 to n do if a[i+1]=a[1] then write (i+1:3) ;

    writeln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на Паскале, которая формирует случайным образом массив из n - целых чисел, лежащих в диапозоне от 1 до 5, вывести сма ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы