Задать вопрос
8 декабря, 02:18

Составить программу вычисления арифметической прогрессии числовой последовательности. Где кол-во элементов и сами элементы вводятся с клавиатуры?

+3
Ответы (1)
  1. 8 декабря, 05:29
    0
    var

    i, p, k, r, s:integer;

    mas: array[1 ... 100] of integer;

    begin

    s:=0;

    read (k) ;

    for i:=1 to k do

    read (mas[i]) ;

    r:=mas[2]-mas[1];

    for i:=1 to k do

    s:=s+mas[i];

    writeln ('raznost progressii=', r, ', summa elementov progressii=', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу вычисления арифметической прогрессии числовой последовательности. Где кол-во элементов и сами элементы вводятся с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы