Задать вопрос
7 ноября, 12:46

Составьте программу (Паскаль) для определения количества цифр в записи произвольного натурального числа. Сейчас проходим while, судя по всему его и надо использовать.

+5
Ответы (1)
  1. 7 ноября, 14:56
    0
    Var n, p, k:integer;

    begin

    readln (n) ;

    p:=n;

    while p 0 do begin

    k:=k+1;

    p:=p div 10;

    end;

    writeln ('k=', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу (Паскаль) для определения количества цифр в записи произвольного натурального числа. Сейчас проходим while, судя по ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы