Задать вопрос
10 апреля, 12:16

Задания на PascalABC. Опишите как можно подробнее ход решения.

№1. Дан одномерный целочисленный массив. Определить количество чисел, кратных 5.

№2. Дан одномерный вещественный массив. Найти сумму положительных элементов, произведение элементов, индексы которых четны.

№3. Составьте программу заполнения массива, не используя клавиатуру, числами: 2, 4, 6, 8, 10, 12, 14, 16, 18, 20.

Заранее благодарю.

+1
Ответы (1)
  1. 10 апреля, 15:37
    0
    1) Program z1;

    var a: array [1 ... 1000] of integer;

    n, c, i: integer;

    begin

    readln (n) ;

    c : = 0;

    for i : = 1 to n do readln (a[i]) ;

    for i : = 1 to n do if (a[i] mod 5 = 0) then inc (c) ;

    writeln (c) ;

    readln;

    end.

    3) var a: array [1 ... 10] of integer;

    i: byte;

    begin

    for i:=1 to 10 do

    a [ i ] : = 2*i;

    begin

    for i:=1 to 10 do

    write (a[i]:4) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задания на PascalABC. Опишите как можно подробнее ход решения. №1. Дан одномерный целочисленный массив. Определить количество чисел, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы