Задать вопрос
18 сентября, 23:21

Дано целое число X и натуральное число N. Составте алгоритм вычисления X^N. Напишите программу на Паскале.

+2
Ответы (1)
  1. 19 сентября, 02:18
    0
    поправьте меня если ^ это не указатель стпени, но если это степень то вот очень просто:

    var a, x:extended; n, i:longint;

    Begin

    read (x) ;

    read (n) ;

    a:=1;

    for i:=1 to n do

    a:=a*x;

    writeln (a:0:0) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано целое число X и натуральное число N. Составте алгоритм вычисления X^N. Напишите программу на Паскале. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы