Задать вопрос
18 сентября, 21:17

Составить программу для данного условия: Вычисление суммы только положительных чисел из последовательно введенных чисел (остановить обработку при 100.0). В Паскале

+1
Ответы (2)
  1. 18 сентября, 23:10
    0
    Var a, s:real;

    begin

    s:=0;

    repeat

    readln (a) ;

    if a>0 then s:=s+a;

    until s>=100;

    writeln ('s = ', s:5:1) ;

    end.

    Пример:

    45

    -84

    12

    30

    -30

    53

    s = 140.0
  2. 18 сентября, 23:19
    0
    Вычисление суммы только положительных чисел из последовательно введенных чисел (остановить обработку при 100.0)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для данного условия: Вычисление суммы только положительных чисел из последовательно введенных чисел (остановить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы