Задать вопрос
23 ноября, 13:57

Воробей Джек прыгает по изгороди с колышка на соседний колышек. Каждый прыжок занимает у него 1 секунду. Он делает A прыжков вперед, потом B прыжков назад (B Формат ввода:

N A B

Пример ввода:

11 4 1

Формат вывода:

k - минимальное количество секунд

Пример вывода:

14

pascal

+4
Ответы (1)
  1. 23 ноября, 17:34
    0
    Var

    ans, n, a, b, i, j:integer;

    begin

    Readln (n, a, b) ;

    i: = 1; ans:=0;

    while true do begin

    for j: = 1 to a do

    if i + j > n then break

    else ans: = ans + 1;

    i: = i + a;

    if i > = n then break;

    i: = i - b;

    ans: = ans + b;

    end;

    Writeln (ans) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Воробей Джек прыгает по изгороди с колышка на соседний колышек. Каждый прыжок занимает у него 1 секунду. Он делает A прыжков вперед, потом ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы