Задать вопрос
4 ноября, 09:44

Составить программу на языке паскаль

задание: дана матрица А (N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

+1
Ответы (1)
  1. 4 ноября, 12:53
    0
    Var n, i, j, ans : integer;

    a : array[,] of integer;

    begin

    read (n) ;

    ans : = 0;

    SetLength (a, n + 1, n + 1) ;

    for i : = 1 to n do

    for j : = 1 to n do

    read (a[i, j]) ;

    for i : = 1 to n do

    for j : = i + 1 to n do

    if (a[i, j] > 0) then

    ans : = ans + 1;

    writeln (ans) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на языке паскаль задание: дана матрица А (N, N). Составить программу подсчета количества положительных элементов, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы