Задать вопрос
20 июня, 21:39

Помогите написать программу в Паскале.

Задано натуральное число n (n ≤ 9999). Определить количество цифр числа n^2.

+2
Ответы (1)
  1. 21 июня, 01:01
    0
    Первый способ:

    Var n:longint;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    n:=n*n;

    if frac (Ln (n) / Ln (10)) > 0 then WriteLn (int (Ln (n) / Ln (10)) + 1)

    else WriteLn (Ln (n) / Ln (10))

    End.

    Второй способ:

    Var

    n, k:longint;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    k:=0;

    n:=n*n;

    While n > 0 do

    Begin

    k:=k+1;

    n:=n div 10

    End;

    WriteLn (k) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в Паскале. Задано натуральное число n (n ≤ 9999). Определить количество цифр числа n^2. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы