Задать вопрос
28 февраля, 00:29

Напишите программу, которая выводит все простые числа в диапазоне от 2 до N (N заранее неизвестно).

Входные данные

Входная строка содержит целое число N.

Выходные данные

Программа должна вывести все простые числа в диапазоне от 2 до N в одну строку, разделив их пробелами.

Примеры

входные данные

20

выходные данные

2 3 5 7 11 13 17 19

+3
Ответы (1)
  1. 28 февраля, 02:31
    0
    Var

    A, N, d:integer;

    Begin

    Write ('N = ') ; ReadLn (N) ;

    For N: = 2 to N do

    Begin

    d:=0;

    A:=2;

    Repeat

    if N mod A = 0 then d:=d+1;

    A:=A+1

    Until A>Sqrt (N) + 1;

    if d = 0 then Write (N,' ')

    End

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая выводит все простые числа в диапазоне от 2 до N (N заранее неизвестно). Входные данные Входная строка содержит ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы