Задать вопрос
27 февраля, 22:41

Помогите составить программу

Вычислить время T встречи автомобилей, движущихся равноускоренно навстречу друг другу, если известны их скорости V1, V2, ускорения a1, a2 и начальное расстояние S между ними.

+5
Ответы (1)
  1. 27 февраля, 22:53
    0
    var V1, V2, a1, a2, S, T:real;

    begin

    writeln ('Введите начальные скорости автомобилей') ;

    read (V1, V2) ;

    writeln ('Введите ускорения автомобилей') ;

    read (a1, a2) ;

    writeln ('Введите начальное расстояние между автомобилями') ;

    read (S) ;

    T:=abs ((- (V1 + V2)) + sqrt (sqr (V1 + V2) + (a1+a2) * 2*s) / (a1+a2)) ;

    writeln (T) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу Вычислить время T встречи автомобилей, движущихся равноускоренно навстречу друг другу, если известны их ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы