Задать вопрос
2 июля, 14:02

Напишите программу (Pascal)

Найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.

+2
Ответы (1)
  1. 2 июля, 14:15
    0
    Program n1;

    var sum, a, c: integer;

    begin

    readln (a) ;

    sum:=0;

    while true do

    begin

    readln (c) ;

    if c=0 then break;

    if c mod a=0 then sum:=sum+c;

    end;

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу (Pascal) Найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы