Задать вопрос
2 ноября, 13:46

Напишите программу в pascal abc

Для первых n натуральных чисел вычислить сумму чисел, кратных 3 и сумму всех чисел.

+5
Ответы (1)
  1. 2 ноября, 16:21
    0
    Var

    n, S, S3:integer;

    Begin

    Write ('n = ') ;

    ReadLn (n) ;

    For n: = 1 to n do

    Begin

    S:=S+n;

    if n mod 3 = 0 then S3:=S3+n;

    End;

    WriteLn ('Сумма чисел [1 ... ', n,'], кратных трём: ', S3) ;

    WriteLn ('Сумма всех чисел [1 ... ', n,']: ', S) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в pascal abc Для первых n натуральных чисел вычислить сумму чисел, кратных 3 и сумму всех чисел. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы