Задать вопрос
2 ноября, 16:15

Напишите программу в которой значение вычисляется по формуле a+b, если а - нечетное число и а*b, если а - четное число (if a mod не равно 0)

+2
Ответы (2)
  1. 2 ноября, 17:21
    0
    Var a, b: integer;

    begin

    read (a, b) ;

    if odd (a) then

    write (a + b)

    else

    write (a * b) ;

    end.
  2. 2 ноября, 18:50
    0
    Program prog

    var a, b, c:integer;

    begin

    writeln ('Введите число a, b') ;

    readln (a, b) ;

    if (not odd (a)) then

    c:=a+b

    else

    c:=a*b;

    writeln (c) ;

    end.

    Паскаль
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в которой значение вычисляется по формуле a+b, если а - нечетное число и а*b, если а - четное число (if a mod не равно 0) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы