Задать вопрос
27 января, 04:37

Программа получает на вход целые числа, не равные 0. Количество введенных чисел неизвестно, последовательность чисел заканчивается 0. Введенные числа по модулю не превышают 30000. Программа должна ответить на вопрос: верно ли, что максимальное из чисел превышает минимальное больше чем в 2 раза?

+5
Ответы (1)
  1. 27 января, 08:20
    0
    Var A, Max, Min:integer;

    Begin

    ReadLn (A) ;

    Max:=A;

    Min:=A;

    While A0 do

    Begin

    ReadLn (A) ;

    if A>Max then Max:=A;

    if A
    End;

    WriteLn (Max/Min > 2)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Программа получает на вход целые числа, не равные 0. Количество введенных чисел неизвестно, последовательность чисел заканчивается 0. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы