Задать вопрос
6 ноября, 00:43

задается целое число N. нужно вывести количество четных делителей числа N.

Формат входных данных

Единственная строка входного файла содержит единственное целое число N (1<=N<=1000)

Формат выходных данных

выведите ответ к задаче

+5
Ответы (1)
  1. 6 ноября, 01:40
    0
    Var

    i, n, k: integer;

    begin

    read (n) ;

    for i : = 1 to n do

    if (i mod 2 = 0) and (n mod i = 0) then

    k : = k + 1;

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы