Задать вопрос
22 августа, 03:56

Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры

+2
Ответы (1)
  1. 22 августа, 06:53
    0
    Прости, что отвечаю через 2 часа, был не дома)

    var

    i, j, n : integer;

    flag : boolean;

    begin

    write ('n = ') ;

    read (n) ;

    for i : = 2 to n do begin

    flag : = true;

    for j : = 2 to i-1 do

    if (i mod j = 0) then begin

    flag:=false;

    break;

    end;

    if flag = true then write (i, ' ') ;

    end;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы