Задать вопрос
22 августа, 10:47

Составить программу нахождения суммы чисел четырехзначного числа

+1
Ответы (1)
  1. 22 августа, 13:00
    0
    Program exs;

    var a, i, sum : integer;

    begin

    sum: = 0;

    readln (a) ; {Считывание числа}

    for i: = 1 to 4 do begin

    sum:=sum + (a mod 10) ; {Находим остаток от деления на 10}

    a:=a div 10; {Выкидываем найденную цифру из числа}

    end;

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу нахождения суммы чисел четырехзначного числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы