Задать вопрос
5 сентября, 01:00

Найти стоимость заданного количества ткани. Цена и количество вводятся с клавиатуры. (Составьте программу Паскаль)

Язык программы Паскаль.

+3
Ответы (1)
  1. 5 сентября, 01:22
    0
    Var

    a, b, c: integer;

    x, y, z:string;

    begin

    x:='рубль';

    y:='рубля';

    z:='рублей';

    writeln ('Сколько стоит метр ткани? (в рублях) ') ;

    readln (a) ; writeln ('Сколько вы хотите купить ткани? (в метрах квадратных) ') ; readln (b) ;

    c:=a*b;

    if c=1 then

    begin

    writeln ('Это будет стоить',' ', c,' ', x) ;

    end;

    if (2<=c) and (c<=4) then

    begin

    writeln ('Это будет стоить',' ', c,' ', y) ;

    end;

    if (5 < = c) and (c < = 1000000) then

    begin

    writeln ('Это будет стоить',' ', c,' ', z) ;

    end;

    end.

    В зависимости от результата программа будет выводить разное окончание.

    1 рубль;

    3 рубля;

    100 рублей.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти стоимость заданного количества ткани. Цена и количество вводятся с клавиатуры. (Составьте программу Паскаль) Язык программы Паскаль. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы