Задать вопрос
30 мая, 08:16

Помогите решить задачу в Paskal:

Составьте программу для решения задачи, которая проверяет, может ли ребёнок посещать детский сад, т. еего возраст до 6 лет. Посчитайте через сколько лет он станет школьником.

+5
Ответы (1)
  1. 30 мая, 11:02
    0
    Program Test;

    Var Vozrast: integer; Bol, Mistake: boolean;

    Begin

    Bol : = true;

    Write ('Введите возраст ребенка: ') ;

    Readln (Vozrast) ;

    Writeln () ;

    if (Vozrast > 6) then

    Writeln ('Ребенок не может посещать детский сад')

    else if (Vozrast < = 0) then

    begin

    Writeln ('Некорректный ввод данных!') ;

    Mistake : = true;

    end

    else

    begin

    Writeln ('Ребенок может посещать детский сад') ;

    Bol : = false;

    end;

    if (Mistake = false) then

    begin

    if (Bol = false) then

    Writeln ('Ребенок станет школьником через ', 7 - Vozrast, ' лет')

    else

    Writeln ('Ребенок уже в школе') ;

    end;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить задачу в Paskal: Составьте программу для решения задачи, которая проверяет, может ли ребёнок посещать детский сад, т. еего ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы