Задать вопрос
12 августа, 16:19

Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти ошибку. Вот задание: Написать программу, подсчитывающую среднее арифметическое всех элементов массива.

var i, n:integer;

g: real;

a:array[1 ... 10] of integer;

begin

for i:=1 to 10 do

begin

write ('введите ', i,'элемент') ;

read (a[i]) ;

end;

n:=0;

for i:=1 to 10 do

n:=n+a[i];

write (n) ;

g:=n/10;

write (g) ;

end.

+1
Ответы (1)
  1. 12 августа, 17:43
    0
    У Вас всё считает правильно, но рекомендую Вам изучить вопрос: "В чем отличие между Write и Writeln?"

    При выводе добавьте "ln"
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти ошибку. Вот задание: Написать программу, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы