Задать вопрос
13 августа, 04:00

Напишите программу на языке программирования (или составьте алгоритм). Дано натуральное число n. Определите, сколько раз цифра "7" встречается в записи данного числа.

+1
Ответы (1)
  1. 13 августа, 06:10
    0
    var

    a, b, k:integer;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    k:=0;

    while a0 do

    begin

    b: = a mod 10;

    a: = a div 10;

    if b=7 then k:=k+1;

    end;

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на языке программирования (или составьте алгоритм). Дано натуральное число n. Определите, сколько раз цифра "7" ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы