Задать вопрос
15 апреля, 08:38

Составьте программу нахождения трёхзначного числа, куб суммы цифр которого равен ему самому

+4
Ответы (1)
  1. 15 апреля, 12:37
    0
    var

    a, b, c, n:integer;

    begin

    for n:=100 to 999 do

    begin

    a: = n div 100;

    b: = n div 10 mod 10;

    c: = n mod 10;

    if (a+b+c) * (a+b+c) * (a+b+c) = n then writeln (n) ;

    end;

    end.

    и в результате получаем, что это число 512
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу нахождения трёхзначного числа, куб суммы цифр которого равен ему самому ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы