Задать вопрос
13 августа, 00:26

Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы S=X+X^2 + ... + X^n и проверьте ее работу при различных значениях X и натурального N

+3
Ответы (1)
  1. 13 августа, 02:54
    0
    Var

    s, cur: longint;

    x, n, i: integer;

    begin

    write ('x=') ; read (x) ;

    write ('n=') ; read (n) ;

    cur : = 1; s : = 0;

    for i : = 1 to n do begin

    cur : = cur * x;

    s : = s + cur;

    end;

    writeln ('sum=', s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы S=X+X^2 + ... + X^n и проверьте ее работу при ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы