Задать вопрос
29 января, 17:22

Написать программу, которая формирует одномерный массив (массив температур), вычисляет среднее арифметическое положительных элементов массива M[1 ... 30]

+5
Ответы (1)
  1. 29 января, 17:30
    0
    Var a:array[1 ... 30] of integer;

    i, sr, k:integer;

    begin

    for i:=1 to 30 do begin

    read (a[i]) ;

    if a[i]>0 then begin sr+=a[i]; inc (k) ; end;

    end;

    writeln (sr/k:3:2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая формирует одномерный массив (массив температур), вычисляет среднее арифметическое положительных элементов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы