Задать вопрос
27 августа, 05:30

Получите из заданного одномерного целочисленного массива А размером 20 элементов массив В, который будет содержать значения, противоположные элементам первого массива.

+3
Ответы (1)
  1. 27 августа, 06:16
    0
    Под противоположными элементами я так понимаю подразумевается зеркальное отражение например первый в последний, второй в предпоследний и тд

    const

    n = 20;

    var

    i: integer;

    a, b: array[1 ... n] of integer;

    begin

    for i : = 1 to n do

    begin

    a[i]: = random (100) - 50;

    write (a[i], ' ') ;

    end;

    writeln;

    for i : = 1 to n do

    begin

    b[i]: = a[n - (i-1) ];

    write (b[i], ' ') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Получите из заданного одномерного целочисленного массива А размером 20 элементов массив В, который будет содержать значения, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
С клавиатуры задается число N не превышающее 20, определяющее количество элементов одномерного целочисленного массива. Затем вручную заполняется сам массив из N элементов.
Ответы (1)
Создать программу получения и обработки одномерного массива - вектора: Вычислить значения 35 элементов одномерного целочисленного массива F в интервале (-6, 10) с использованием генератора случайных чисел
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)