Задать вопрос
11 июня, 17:14

Составить программу, позволяющую в одномерном массиве, состоящем из N вещественных элементов, вычислить: наименьший из элементов массива, принадлежащих отрезку [a, b]

+1
Ответы (1)
  1. 11 июня, 20:05
    0
    Pascal

    const n = 20;

    var

    a, b, min : real;

    m : array [1 ... n] of real;

    i : integer;

    begin

    / / формирова массива не пишу

    readln (a, b) ;

    min : = b;

    for i : = 1 to n do

    if (m[i]=a) and (m[i] <=b)

    then

    min : = m[i];

    writeln (min:3:2) ;

    end.

    Программа будет работать корректно, если в массиве есть хотя бы один элемент, попадающий в диапозон [a ... b].
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, позволяющую в одномерном массиве, состоящем из N вещественных элементов, вычислить: наименьший из элементов массива, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы