Задать вопрос
3 марта, 22:44

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем. (a=0 признак окончания ввода, ноль не входит в последовательность). Программа должна вывести количество и сумму всех чисел последовательности.

+4
Ответы (1)
  1. 4 марта, 02:29
    0
    Var a, b, c: integer;

    begin

    b:=0;

    c:=0;

    readln (a) ;

    while a 0 do

    begin

    b:=b+1;

    c:=c+a;

    readln (a) ;

    end;

    writeln ('Кол-во: ', b) ;

    writeln ('Сумма: ', c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем. (a=0 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы