Задать вопрос
12 июля, 08:03

Помогите написать программу на паскале абс

Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром - это натуральное число, которое читается слева направо и справа налево одинаково. Иначе говоря, отличается симметрией записи (расположения цифр), причём число знаков может быть как чётным, так и нечётным. Например, 165 его палиндром 561.

+4
Ответы (1)
  1. 12 июля, 11:44
    0
    Program palidron;

    var

    a, b, c, x, d: integer;

    begin

    writeln ('Число:') ;

    readln (a) ;

    b: = a mod 10;

    c: = ((a div 10) mod 10) ;

    x: = ((a div 10) div 10) ;

    d: = 100*b+10*c+x;

    writeln ('Палиндром: ', b, c, x) ;

    writeln ('Произведение числа и палиндрома: ', d*a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на паскале абс Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы