Задать вопрос
22 октября, 17:37

Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)

+4
Ответы (1)
  1. 22 октября, 21:25
    0
    uses crt;

    Var x, y, k:integer;

    procedure delit;

    begin k:=0;

    writeln ('Делители числа ', x, ':') ;

    for y:=1 to x do if x mod y=0 then

    begin

    write (y, ' ') ;

    k:=k+1

    end;

    writeln ('Количество делителей числа ', x, ' равно ', k) ;

    end;

    begin clrscr;

    writeln ('Введите число: ') ;

    readln (x) ;

    delit;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы