Задать вопрос
22 октября, 13:15

Дан массив a из n целых чисел. Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных

На первой строке входного файла записано натуральное число nn (n≤100) (n≤100) - число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000) (|ai|≤1000) - элементы массива aa.

Формат выходных данных

Требуется через пробел вывести два числа - количество положительных и количество отрицательных элементов массива.

Примеры

входные данные:

3

-2 0 5

выходные данные

1 1

+3
Ответы (1)
  1. 22 октября, 14:34
    0
    Var

    i, c, k, n: integer;

    ar: array[1 ... 10000]of integer;

    begin

    c : = 0;

    k : = 0;

    readln (n) ;

    for i : = 1 to n do

    begin

    read (ar[i]) ;

    if (ar[i] > 0) then c : = c + 1;

    if (ar[i] < 0) then k : = k + 1;

    end;

    write (c, ' ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив a из n целых чисел. Требуется посчитать количество положительных элементов и количество отрицательных элементов. Формат входных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы