Задать вопрос
10 января, 00:45

Составить программу замены значений переменных a и b (пусть дано : a=3, b=5; требуется получить a=5, b=3)

Запись команд присваивания a:=b; b:=a; приведет к получению неверного результата: a=b=5 (убедитесь в этом!).

+1
Ответы (1)
  1. 10 января, 03:23
    0
    Программа с использованием вспомогательной переменной:

    var a, b, c:integer;

    begin

    readln (a, b) ;

    c:=a;

    a:=b;

    b:=c;

    writeln (a,' ', b) ;

    end.

    Пример:

    3 5

    5 3
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу замены значений переменных a и b (пусть дано : a=3, b=5; требуется получить a=5, b=3) Запись команд присваивания a:=b; ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы