Задать вопрос
17 декабря, 00:11

По данному фрагменту кода выясните, какими числами заполняется целочисленный массив А из десяти элементов:

А[1]:=10;

x:=3;

y:=-1;

for i:=2 to 10 do

begin

x:=x+2;

y:=y * (-1) ;

А[i]:=А[i-1]-x*y;

end;

Найдите сумму элементов массива с чётными индексами. В ответе укажите только число, без каких-либо знаков препинания, например, 100

+5
Ответы (1)
  1. 17 декабря, 00:20
    0
    Код полностью

    var

    a: array[1 ... 10] of integer;

    x, y, i, s: integer;

    begin

    a[1] : = 10;

    x : = 3;

    y : = - 1;

    for i : = 2 to 10 do

    begin

    x : = x + 2;

    y : = y * (-1) ;

    a[i] : = a[i - 1] - x * y;

    write (a[i], ' ') ;

    if i mod 2 = 0 then s : = s + a[i];

    end;

    writeln;

    writeln (s) ;

    end.

    Ответ 5
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «По данному фрагменту кода выясните, какими числами заполняется целочисленный массив А из десяти элементов: А[1]:=10; x:=3; y:=-1; for i:=2 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы