Задать вопрос
30 июля, 15:57

Помогите решить задачи по turbo pascal. 1) Найти сумму элементов массива целых чисел в количестве 20 меньше данного числа 2. 2) Найти все элементы массива целых чисел в количестве 20 удовлетворяющие условиям остаток от деления на 5 равен 3. 3) Найти индексы элементов массива вещественных чисел, отрезки которых принадлежат отрезу A B. 4) Выдать на экран элементы массива целых чисел в количестве 20, которые больше среднего арифметического элемента массива. Буду очень благодарен.

+1
Ответы (1)
  1. 30 июля, 16:58
    0
    1) Немного не понял фразу "меньше данного числа 2". Если найти сумму всех элементов, которые меньше двух в массиве размером 20 элементов, то это

    var s, i:longint;

    m:array[1 ... 100] of integer;

    begin

    for i:=1 to 20 do

    read (m[i]) ;

    s:=0;

    for i:=1 to 20 do

    if m[i]<2 then s:=s+m[i];

    writeln (s) ;

    end.

    2)

    var i:longint;

    m:array[1 ... 100] of integer;

    begin

    for i:=1 to 20 do

    read (m[i]) ;

    for i:=1 to 20 do

    if (m[i] mod 5=3) then writeln (m[i]) ;

    end.

    3) var a, b, i:longint;

    m:array[1 ... 100] of real;

    begin

    read (a) ;

    read (b) ;

    for i:=1 to 20 do

    read (m[i]) ;

    for i:=1 to 20 do

    if (m[i]>=a) and (m[i]<=b) then writeln (i) ;

    end.

    4) var

    o, s, i:longint;

    m:array[1 ... 100] of integer;

    begin

    for i:=1 to 20 do

    begin

    read (m[i]) ;

    s:=s+m[i];

    end;

    o:=s div 20;

    for i:=1 to 20 do

    if m[i]>o then writeln (m[i]) ;

    end.

    Прошу прощения, если есть ошибки в синтаксисе. Нет возможности проверить в компиляторе
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить задачи по turbo pascal. 1) Найти сумму элементов массива целых чисел в количестве 20 меньше данного числа 2. 2) Найти все ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)