Задать вопрос
23 февраля, 16:35

Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3. 3) В массиве из 8 целых найти номер массива с наибольшим значением. 4) В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5) Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

+1
Ответы (1)
  1. 23 февраля, 17:02
    0
    1) Program Massiv1;

    Uses Crt;

    var k:array[1 ... 12] of real;

    i, c:integer;

    begin

    clrscr;

    write ('Введите элементы массива k:') ;

    c:=0;

    for i:=1 to 12 do

    begin

    readln (k[i]) ;

    if (k[i]<0) then Inc (c) ;

    end;

    writeln;

    writeln;

    for i:=1 to 12 do write (k[i]:4:4) ;

    writeln;

    writeln ('Количество элементов <0:', c) ;

    readkey;

    end.

    2) Program Massiv2;

    Uses Crt;

    var m:array[1 ... 10] of integer;

    i, c:integer;

    begin

    clrscr;

    write ('Введите элементы массива m:') ;

    c:=0;

    for i:=1 to 10 do

    begin

    readln (m[i]) ;

    if (m[i]=3) then Inc (c) ;

    end;

    writeln;

    writeln;

    for i:=1 to 12 do write (m[i]:4) ;

    writeln;

    writeln ('Количество элементов = 3:', c) ;

    readkey;

    end.

    В третьем задании видимо имеется ввиду номер элемента этого массива, т. к по условию задачи массив у нас один.

    3) Program Massiv3;

    Uses Crt;

    var m:array[1 ... 8] of integer;

    i, c, max:integer;

    begin

    clrscr;

    write ('Введите элементы массива m:') ;

    c:=0;

    for i:=1 to 8 do readln (m[i]) ;

    writeln;

    writeln;

    max:=m[1]

    for i:=1 to 8 do

    begin

    if (m[i]>max) then

    begin

    max:=m[i];

    c:=i

    end;

    write (m[i]:4) ;

    end;

    writeln ('Индекс максимального элемента = : ', c) ;

    readkey;

    end.

    4) Program Massiv4;

    Uses Crt;

    var m:array[1 ... 12] of integer;

    i, c, max, sum:integer;

    begin

    clrscr;

    write ('Введите элементы массива m:') ;

    c:=0; sum:=0;

    for i:=1 to 12 do readln (m[i]) ;

    writeln;

    writeln;

    max:=m[1]

    for i:=1 to 12 do

    begin

    if (m[i]>max) then

    begin

    max:=m[i];

    c:=i

    end;

    write (m[i]:4) ;

    end;

    for i:=1 to c-1 do sum:=sum+m[i];

    writeln ('Количество элементов расположенных до max : ', с-1) ;

    writeln ('Сумма элементов расположенных до max : ', sum) ;

    readkey;

    end.

    В пятом задании видимо имеется ввиду значения элементов массива меньшие чем сумма первого и последнего

    5) Program Massiv5;

    Uses Crt;

    var k:array[1 ... 15] of real;

    sum:real;

    i, c:integer;

    begin

    clrscr;

    write ('Введите элементы массива k:') ;

    c:=0;

    for i:=1 to 15 do readln (k[i]) ;

    sum:=k[1]+k[15];

    writeln;

    writeln;

    for i:=1 to 15 do

    begin

    write (k[i]:4:4) ;

    if (k[i]
    end;

    writeln;

    writeln ('Количество элементов : ', c) ;

    readkey;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы