Задать вопрос
2 января, 03:10

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3. Программа получает на выход целые числа. Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Количество чисел не превышает 20. Введенные числа [-30; 30]. Программа должна вывести одно число: количество четных чисел, кратных 3.

Буду признательна!

+2
Ответы (1)
  1. 2 января, 05:34
    0
    Program n1;

    const n=20;

    var a: array [1 ... n] of integer;

    i, k: integer;

    begin

    k:=0;

    for i:=1 to n do

    begin

    write ('введите ', i,' число: ') ;

    readln (a[i]) ;

    if (a[i]=0) or (a[i]=30) then break;

    if (a[i] mod 2=0) and (a[i] mod 3=0) then k:=k+1;

    end;

    writeln ('количество: ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3. Программа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы